Visualisation of superquadric particles

Submitted by t9000 on Wed, 05/16/2018 - 11:03

Dear all,

i want to simulate superquadric particles but can't find a feasible way to visualize my simulation data with paraview. Is there any simple solution that works right now?

Best regards

Tobi

richti83's picture

richti83 | Wed, 05/16/2018 - 13:40

You need
- right dump file format (dump local)
- rigid reader (from github)
- python programmable filter (add via tools->manage custom filters->[import])
- a source "superquadric" in PV
see this post for all needed files and a screenshot of sq configuration on PV:
https://www.cfdem.com/forums/tutorial-4-superquadric-angle-repose-repres...

best,
Christian

t9000 | Fri, 05/18/2018 - 12:41

It needed just a simple filter modification that I'd seen in one of your older posts. :)

I had to change

CLUMP_ID=P.GetArray("c_id").GetValue(body);

back to

CLUMP_ID=P.GetArray("id").GetValue(body);

Tobi

arnom's picture

arnom | Tue, 05/22/2018 - 09:56

Hi Tobi,

we will release a ParaView plugin with the next LIGGGHTS release at the end of June that should satisfy all your needs.

Kind Regards,
Arno

DCS team member & LIGGGHTS(R) core developer

Rachel | Wed, 05/23/2018 - 00:49

Hi Arno,

That's a good new. One more question: is there any plan to incorporate this superquadric function in the public version of CFDEM coupling? Thank you very much.

Best,
Rachel

arnom's picture

arnom | Thu, 05/24/2018 - 08:57

Hi Rachel,

this work is unpublished and not ready for production so I'm afraid it won't happen soon.

Kind regards,
Arno

DCS team member & LIGGGHTS(R) core developer

mhallee | Sun, 07/29/2018 - 02:51

Hi Arno,

Has this plugin been released? What should I look for?

~Mitchell

PRATBHARAT94 | Sat, 06/20/2020 - 04:53

Hello all experts,
I have to fill a cylinder container with cylindrical particles . To start my simulation, I first checked whether superquadric package was working or not. So. in.particle_particle was working well. But when I modifying this script using fix command it is showing following error : ERROR: Fix particletemplate/superquadric (id pts1): fix particletemplate/superquadric currently supports only constant blockiness params (fix_template_superquadric.cpp:366)
I have tried using both in.particle_particle script as well as in.chute_wear also. In both case I am getting same error.
Here, I am attaching in.chute_wear script:
#Simple chute wear test

echo both

atom_style superquadric
atom_modify map array
boundary f f f
newton off

communicate single vel yes

units si

region domain block -0.5 0.1 -0.2 0.2 -0.4 0.15 units box
create_box 1 domain

neighbor 0.002 bin
neigh_modify delay 0

#Material properties required for new pair styles

fix m1 all property/global youngsModulus peratomtype 5.e6
fix m2 all property/global poissonsRatio peratomtype 0.45
fix m3 all property/global coefficientRestitution peratomtypepair 1 0.3
fix m4 all property/global coefficientFriction peratomtypepair 1 0.5
fix m5 all property/global coefficientRollingFriction peratomtypepair 2 0.5 0.5 0.5 0.5
fix m6 all property/global characteristicVelocity scalar 1.0
fix m7 all property/global coefficientRollingViscousDamping peratomtypepair 2 0.0 0.0 0.0 0.0
fix m8 all property/global k_finnie peratomtypepair 1 1.0

#New pair style
pair_style gran model hertz tangential history #Hertzian without cohesion
#pair_style gran model hertz tangential history rolling_friction off surface superquadric #Hertzian without cohesion
pair_coeff * *

timestep 0.00001

fix gravi all gravity 9.81 vector 0.0 0.0 -1.0

#the chute
fix cad all mesh/surface/stress file meshes/simple_chute.stl type 1 wear finnie
fix inface all mesh/surface file meshes/insertion_face.stl type 1
fix granwalls all wall/gran model hertz tangential history surface superquadric mesh n_meshes 1 meshes cad

#distributions for insertion

fix pts1 all particletemplate/superquadric 123457 atom_type 1 density constant 2500 shape constant 0.0015 0.0025 0.0035 blockiness 4.0 4.0 quat 1 0 0 0 #omegaz 10

#fix pts2 all particletemplate/superquadric 123457 atom_type 1 density constant 2500 shape constant 0.0015 0.0025 0.0035 blockiness 2.0 3.0
#fix pts2 all particletemplate/sphere 15485867 atom_type 1 density constant 2500 radius constant 0.0025
fix pdd1 all particledistribution/discrete 32452843 2 pts1 0.3 pts2 0.7

#region and insertion
group nve_group region domain
region bc cylinder z 0.0 0.0 0.015 0.05 0.12 units box

#particle insertion
fix ins nve_group insert/stream seed 32452867 distributiontemplate pdd1 & nparticles 6000 massrate 0.1 insert_every 1000 overlapcheck yes all_in no vel constant 0.0 0.0 -1.0 & insertion_face inface

#apply nve integration to all particles that are inserted as single particles
fix integr nve_group nve/superquadric

#output settings, include total thermal energy
compute 1 all erotate/superquadric
thermo_style custom step atoms ke c_1 vol
thermo 1000
thermo_modify lost ignore norm no

#insert the first particles so that dump is not empty
run
dump dmp all custom/vtk 200 post/chute_*.vtk id type type x y z ix iy iz vx vy vz fx fy fz omegax omegay omegaz radius shapex shapey shapez quat1 quat2 quat3 quat4 blockiness1 blockiness2 tqx tqy tqz angmomx angmomy angmomz
dump dumpstress all mesh/gran/VTK 200 post/mesh_*.vtk stress wear cad

#insert particles
run 100000 upto
unfix ins

Thanks a lot

richti83's picture

richti83 | Sun, 06/21/2020 - 12:35

There is a missing word in the doc of particletemplate/superquadric it should read:

fix pts1 all particletemplate/superquadric 123457 atom_type 1 density constant 2500 shape constant 0.0015 0.0025 0.0035 blockiness constant 4.0 4.0

https://www.cfdem.com/forums/some-notes-v-380
best,
Christian.