Open MPI installation problem

Submitted by serdarhd on Wed, 01/23/2019 - 14:53

Hi All,

I try to install Open MPI, which is prerequiste for liggghts. Some info about my current Suse version :

NAME="SLED"
VERSION="12-SP3"
VERSION_ID="12.3"
PRETTY_NAME="SUSE Linux Enterprise Desktop 12 SP3"
ID="sled"

I installed Open MPI 1.6 by typing

./configure --prefix=$HOME/openmpi
make all
make install

Here, it is discussed that openmpi 1.6 is compatible with OpenSuse 12.3 https://public.kitware.com/pipermail/paraview/2014-February/030487.html https://build.opensuse.org/package/show/openSUSE:12.3/openmpi

To add OpenMPI to my path and LD_LIBRARY_PATH, I execute the following comands on terminal:

export PATH=$PATH:/usr/lib64/mpi/gcc/openmpi/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/mpi/gcc/openmpi/lib64

Then, in /liggghts/src directory, I execute make auto, this appears :

Creating list of contact models completed.
make[1]: Entering directory '/home/hicd_se-a/liggghts/LIGGGHTS-PUBLIC/src/Obj_auto'
Makefile:456: *** 'Could not compile a simple MPI example. Test was done with MPI_INC="" and MPICXX="mpicxx"'. Stop.
make[1]: Leaving directory '/home/hicd_se-a/liggghts/LIGGGHTS-PUBLIC/src/Obj_auto'
Makefile:106: recipe for target 'auto' failed
make: *** [auto] Error 2

Do you have any idea what the problem is here ? I went through the "makefile" but it looks like quite complicated as linux beginner like me.

serdarhd | Wed, 01/23/2019 - 16:15

I solved it. The problem was about incorrect path.
When I changed it as

PATH=$HOME/openmpi/bin:$PATH
LD_LIBRARY_PATH=$HOME/openmpi/lib:$LD_LIBRARY_PATH

it works.