Errors using TwoWayFiles data exchange mode

Submitted by Minghao on Mon, 04/09/2018 - 20:35

Dear all,

I would like to run a case without MPI. I have modified the and as following.

1) :
#call function to run a CFD-DEM case
CFDrun $logpath $logfileName $casePath $headerText $solverName $debugMode

#call function to run a DEM case
DEMrun $logpath $logfileName $casePath $headerText $solverName $debugMode

In CFD/constant/couplingProperties, I used

dataExchangeModel twoWayFiles;
couplingFilename "VTK_OUT%4.4d.vtk";
DEMts 0.0001;
maxNumberOfParticles 10100;

Then the error report is:
You are currently using:
OF version: 3.0.x
OF build: 3.0.x-221b8ab77307
CFDEM build: 3.8.0-3-gb237264-dirty


setCG() not executed correctly!

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::error::abort() at ??:?
#2 Foam::cfdemCloud::cfdemCloud(Foam::fvMesh const&) at ??:?
#3 main at ??:?
#4 __libc_start_main in "/lib/x86_64-linux-gnu/"
#5 ? at ??:?

I am now quite confused with the coupling without MPI. Any solutions? Thanks in advance.

wenxin | Tue, 06/18/2019 - 09:57

do you know how to run a cfdem case on a single core? Thanks in advance ~


ErleiLi | Mon, 06/08/2020 - 04:41

I also met the error "setCG() not executed correctly!" when using twoWayFiles dataExchangeModel. I just wonder have you solved this problem?

ErleiLi | Wed, 06/10/2020 - 04:55

I comment one line 291 in dataExchange.H and one line 285 in cfdemCloud.C. Then recompile the SRC lib, it works.

But I do not the meaning of CG. You can also find "void setCG()" in line 121 of oneWayVTK.H and line 160 on twoWayMPI.H. While there is no information in twoWayFiles. I tried to add one line "void setCG() const { particleCloud_.setCG(1.); };" in twoWayFiles.H, error also occures.

Anyhow, the above method works.