ERROR: Invalid dump style (../output.cpp:634)

Submitted by mdvalencia on Fri, 07/31/2020 - 23:58

Hello everybody.

I have just begun to work with LIGGGHTS in a remote cluster. We have compiled the make auto file, and the administrators of the cluster have helped me to modify the make files to be able to compile the files there. After the compilation process and when I try to run the first example I get the compilation error 'ERROR: Invalid dump style (../output.cpp:634)'. Then when I type command mpirun lmp_auto -help in the src folder, I don't find all the dump styles as I see on my laptop. I noticed that the Linux version is: 3.10.0-1127.8.2.el7.x86_64 GNU/Linux.
I am a beginner in remote work. I hope someone could help.
Kind regards


mdvalencia | Sun, 08/02/2020 - 18:32

Hello, thanks for your answer.

I don't get all the dump styles related to vtk.
We have tried several options in the makefile:
-First, we wrote, USE_VTK = "ON", AUTOINSTALL_VTK = "ON", and changed the directories for the VTK_INC_USR=-I/path/to/vtk/include and VTK_LIB_USR=-L/path/to/vtk/lib to the respective directories. With that modification, we obtain that autoinstall couldn't be done, and I must install vtk manually.
-Second, we set AUTOINSTALL_VTK = "OFF", and the compilation says "could not obtain VTK_MAJOR_VERSION".
-Third, the only compilation we achieved was setting USE_VTK = "OFF", and putting AUTOINSTALL_VTK as a comment, but in this way, I can't get any vtk result.

Thank you for your attention.


mschramm | Mon, 08/03/2020 - 06:42

To use the custom/vtk dump style, the USE_VTK flag must be set to ON.
I would not use the AUTOINSTALL_VTK flag for a cluster.
You will need to work with the cluster engineers to make sure the makefile.user_default file points to the correct locations for the VTK_LIB_USR and VTK_INC_USR variables.