Cannot run CFDEMworkbench-starter

Submitted by mrossi2001 on Wed, 09/19/2018 - 22:41

I have successfully installed (seemingly) CFDEMworkbench-starter edition on a Windows -10 64-bit virtual system running on vmware player. No install errors were reported. When I ran the system for the first time, I entered the license, which was accepted. the program never actually ran. When I executed it again by double clicking the desktop icon a CFDEMworkbench.exe has stopped working message dialog box is displayed, with no further information given. I attempted to run as administrator, and with the security software deactivated, without positive result.

A search of the log file directory reveals only one populated log file- the info file. The info file reveals the following:

19/09/2018 15:16:39.843 INFO Starting Application
19/09/2018 15:16:40.500 INFO License data correctly read.
19/09/2018 15:16:40.531 INFO Configuration data correctly read.
This is repeated for every run attempt.

All other log files involve the installation only. Only one file reveals any kind of anomaly: The installationlog file. The last entry reads:

[1748444] Critical: QWindowsPipeWriter: GetOverlappedResult failed. (No process is on the other end of the pipe.)

This error is for the installation only and not reflected in any other type of message.

The following system configuration is used:
Windows 10 64-bit
8 Gig Ram
I allocated 3 processor cores

Do you see any incompatibilities with this configuration?


alice's picture

alice | Wed, 10/03/2018 - 09:46

Hello mrossi2001,

I suspect that the problems are coming from the VM Player. Theoretically, CFDEM(R)workbench can run on virtual machines (this is why the activation worked), but we do not actively support this. If you have the possibility to install the software on a native Windows machine, I would recommend to install it there. Since your license is currently (virtually) in use but you cannot deactivate it from within the workbench (since this does not run), please let us know so we can deactivate it from remote.